PureOS Firefox ESR Ca

Good Day all
Been successful with my Mac and IOS
I’m new to PureOS (Debian) and would dearly love to keep this Librem mini as the main system
This is as far as I get
:~$ mv ~/.pki ~/.pki.mozilla-old
mv: cannot stat ‘/home/chrisray/.pki’: No such file or directory
:~$ cd ~/Downloads
sudo cp “.crt” /usr/local/share/ca-certificates/
sudo update-ca-certificates
**[sudo] password for chrisray: **
cp: cannot stat ‘.crt’: No such file or directory
Updating certificates in /etc/ssl/certs…
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d…

sorry for the Noob level of inquiry , I’ll get better :woozy_face:

We are refactoring this process, as Debian-based systems do not have a nice way of doing this like Mac and other Linux distros. In the meantime, please try this:

sudo mkdir -p /usr/share/ca-certificates/start9
sudo cp "adjective-noun.local.crt" /usr/share/ca-certificates/start9/
sudo bash -c "echo 'start9/adjective-noun.local.crt' >> /etc/ca-certificates.conf"
1 Like

Wow you guys are great
ill give you a report asap
thanks so much

1 Like

well this is what we got mate
cp: cannot stat ‘adjective-noun.local.crt’: No such file or directory
Not sure what Im doing wrong

Where it says “adjective-noun” within the steps provided, you must enter the ones that were created for you when you installed StartOS.

Example: If during the install “funny-boy.local” was created … then “funny-boy” needs to replace “adjective-noun” within the commands.

Note: These commands must be run within the folder where you downloaded the crt - follow these instructions.

Unless I am mistaken and your OS needs other steps.

1 Like

Thanks so much
no good though

sudo mkdir -p /usr/share/ca-certificates/start9
sudo cp “smart-lien.local.crt” /usr/share/ca-certificates/start9/
sudo bash -c “echo ‘start9/smart-lien.local.crt’ >> /etc/ca-certificates.conf”
cp: cannot stat ‘smart-lien.local.crt’: No such file or directory

Greatful for the help

What OS are you using? Is the Firefox install via a snap package?

I just tried a little experiment on my own desktop which is running LinuxLite (based on Debian, Ubuntu LTS)

I was able to get the .local and cert working with the snap package of Firefox (which is the default) but not with the traditional apt install methond (had to force this install).

I then removed the installed apt version of Firefox and went back the the snap package version and as able to get it working again.

I did NOT have to do these steps, so just skip these parts

libnssckbiso=/usr/lib/firefox/libnssckbi.so && sudo mv $libnssckbiso $libnssckbiso.bak && sudo ln -s /usr/lib/x86_64-linux-gnu/pkcs11/p11-kit-trust.so $libnssckbiso

mv ~/.pki ~/.pki.mozilla-old

I also had to import the cert within the Firefox settings > Security > Certificates

Maybe this is helpful

Oh! So you are using PureOS on this Librem mini. I have been meaning to try out this OS!

Yup Pure OS comes with the little guy , I’m liking the Gnome and the learning curve isn’t tough
I got stuff running, after I forced the cert on firefox-uninstalled firefox - went to Gnome Pkg - reinstalled fire fox and eureka !
I used Moun Pkg manager to install firefox the first time and I couldnt use snap
after all that mess something liked what I did
Thanks so much for the help
The fourms on Purism said "the best way to learn is to just dive in!
Sweet! I had so much wanted the Libriem/Embassy to get along


great news! Would you write up a little how-to for the next guy?

Certainly try to ! My back ground is medical not Linux :woozy_face:

Send me your steps! I just installed pure OS to try out myself I’ll see if I can reproduce What You’ve done! It would be my pleasure

Cool beans
Since we have been at this together I think the easiest is to install firefox ESR using the Gnome Packages software-follow the normal set up for linux, then follow our thread if need be
I basically tried everything on this thread except I used Muon Package Manager initially to install FirefoxESR ,after removeing firefox with Muon and reinstalling with Gnome, stuff worked
I would have to start breaking stuff to figure out exactly what to avoid and what worked.
I’m thinking your suggestion of forcing the cert onto firefox may have done it?

Oh and thanks for doing this!

1 Like

i was about to config Specter and
well something changed
Everything was running fine then "Hmm. We’re having trouble finding that site.(Linux PureOS/FirefoxESR)
Checked my Laptop (Mac) and same thing
However when I checked the Phone and the another Mac Mini no problem
Went back to the Laptop switched to safari and back to normal
It seems Firefox browser cant find the site any longer
Safari is having no problem . Not a big fan of Safari, plus wasnt wanting to install it on PureOS
I must be crazy

Did you get this figured out? The error indicates that you are no providing the right path (location) to the .crt file.

No luck
I went back over everything Ive done in the past
The .crt are listed and certified in firefox settings
Running out of time, to keep trying to fix this
Im back to using Safari on my Macs for now

I’m sorry, but I can only provide assistance with additional information. What is the path (location) of your .crt file? You can find it by opening a terminal in the folder of the file and entering the command pwd - or you can get the full path from the file explorer GUI, usually at the top, similar to a URL bar. Once we have the location, we can get it moved properly.

my bad, didn’t know your were trying to help. I’m afraid I don’t understand how to do this , still learning how Linux works. The best I can find is:


Sorry for being such a Noob with this, dont want to waste people’s time

pwd is a command that gives you the “present working directory,” or in other words, where you are in the filesystem.

If Downloads (the directory it returned) is where you downloaded the cert file to, then you’ll want to run the commands from that directory.

We have just published an updated method for adding the cert that is hopefully a bit less confusing. You can find it here (be sure to refresh the page if it seems like the old guide): Start9 | Trusting Your Start9 CA on Linux

1 Like

Thanks for the information
I carefully followed the new guide
No crt found
I tried a different text editor thinking I’m not copy/paste-ing correctly
I’ll try typing without copying if that’s what is wrong