StartOS Interface on Optiplex not connecting to internet

Hi… Wondering if anybody from the community can offer some tips, tricks, advice…

I have an Optiplex 9020 which I have been using with a K3tan Nodebox setup for teaching. It has worked really well for me. For the past few days I have been attempting to switch it over to StartOS without any luck. The OS installs successfully, but the web app interface can’t connect to the internet to retrieve data for the marketplace, updates, etc. The UI remains in a loading (shimmer) state. The updates screen says, “Request failed”.

If I open a new tab in firefox and hit a url like, it will load eventually, but very, very slowly. The OS webapp never connects.

The kernel log shows messages like this for veth0 and veth1:
port 1(veth 0) entered blocking, disabled, promiscuous state.

I’ve tried bare metal installs of free and non free x86_64 iso’s. And followed Cyph3rp9nk’s proxmox tutorial. Same result with each attempt, unfortunately.

I’m hoping somebody from the StartOS community who has experience working with the Optiplex hardware can let me know what worked for them, or offer suggestions for potential fixes. Thanks in advance for any assistance. I’m very keen to get this working.

Does KIOSK mode work for you? Are you just having trouble connecting to it externally?

Have you followed this guide? At what point are you stuck?

I followed the diy-x86 guide when installing StartOS on bare metal. After installation, Firefox did not launch in Kiosk mode. Was it supposed to?

My sticking point is that after the OS gets installed. Running the OS with a monitor, keyboard, and mouse plugged into the machine, I am presented with Firefox at the StartOS login screen. After logging in, I am taken to localhost/home. When I click on Services, no services load. The UI just shimmers as if loading, but no elements ever actually load. When I click on the Updates menu item, the UI shimmers as if loading and eventually a message appears that says, “Request Failed”.

During my first attempt, I connected to the node remotely and got the certificate screen. After adding the certificate, I was not able to connect to the LAN web address. I abandoned resolving the remote connection problem in favor of focusing on the issue with StartOS not connecting to the internet. Figuring that is the more fundamental issue.

I hope this helps…

Have you checked that your server is on the same subnet? You can check by inspecting your IP range. Looks like something with your LAN setup is not right.

Good question. I’ll check during my next attempt. I’ve had to go a different direction to get it running in the short term, but I’ll be trying again.

Kiosk mode is where it just brings up Firefox, on the server, when it’s connected to a monitor itself. It sounds like you’re describing that. The alternative is to connect remotely from another machine on the same subnet, by directing a browser to start.local. Are neither of those methods working?

I see… Yeah, kiosk mode was working with a monitor plugged into the server. For some reason it wasn’t retrieving data from the internet though. Wondering if anybody else has had this issue with this hardware…

It is more likely to be a networking issue than a hardware one, unless you’re trying to use wireless. What symptoms do you have regarding your connection? How is your network configured in regard to this device? I.e., straight into the router, using an extender, using custom firewall or VPN, etc

I’m running StartOS on an Optiplex 980. While this machine has been problematic in a few ways, I have not experienced the specific issue you are describing. Did you get it working?

It is plugged into the router. No wifi. I’ve had ubuntu installed this past week, and it has no issues connecting to the internet. The IP range hasn’t changed, and I was able to access the box when it was running ubuntu via ssh. I haven’t tried connecting via ssh with StartOS on it.

I’ve tried resetting Tor via the experimental features in StartOS, but no luck. Based on the logs, it looks like maybe podman is failing. podman0: port 1(veth1) entered disabled state, but I don’t really know.

I’m running StartOS on an Optiplex 980.

Nice. What issues did you encounter with your Optiplex? Which iso worked for you?

Podman is a red herring.

This still sounds like a networking issue to me. Are you running a VPN or custom firewall on your router? Any other esoteric network setups, like so-called “mesh” systems or extenders?

Podman is a red herring.

Good to know… I won’t spend time exploring that then.

This still sounds like a networking issue to me. Are you running a VPN or custom firewall on your router? Any other esoteric network setups, like so-called “mesh” systems or extenders?

No, nothing. The drive was wiped during the install of Start9 I imagine, so no software based firewall on the node. No special extenders or anything else.

My router is a pretty typical router. I’ve never had issues with it. My node is directly plugged into the router via ethernet. Maybe I should upgrade my modem. Do you have a cable modem that you recommend?

As an aside, I’m taking a hardware and networking course this semester. Hoping to up my sovereign computing game. Even though it’s gonna be very Windows oriented, I’m hoping those concepts will still be applicable.

For VPNs and Firewalls, I mean at the router level. Is this an ISP issued device? By ATT by any chance? Them and Comcast are becoming more intrusive with their equipment these days. You might go in there and see if your device is being blocked for some reason. It’s rare for a router to cause an issue, so it’s hard to say what’s going on here without diving on the network.

The main issue I have, is the system does not boot again after shutdown/reboot, or power out. I have to hard reset it a couple of times. But once it boots, it’s fine, works GREAT. The x86_64-nonfree.iso is the correct image for most DIY hardware.

The modem is ISP issued. That’s why I think I’ll pick up a different one. What’s weird is that the device has no problem connecting to the internet when running Ubuntu (desktop or server). I’m currently running Ubuntu with Tor on it just fine. I can hook it up to a keyboard, mouse and monitor and download files to it all day. I can also ssh into it and do the same. It seems like there is a hardware compatibility issue in this specific optiplex. It is refurbished. When I list the hardware, it’s all Intel stuff though. Seems standard enough. Pretty weird.

If it is a networking issue, then that would indicate that maybe there is something about Start OS’s specific traffic that the ISP’s modem is having an issue with, right? But I’ve gotta think they’re just calling a web service to get a list of apps to display in the marketplace. Just basic web traffic I imagine. Perplexing.

And you’ve set AC Recovery to “Power On” in the BIOS?

It’s not a power on issue. It often, but not always, get’s stuck during the boot process. I haven’t taken the time to narrow down the issue. Once it’s up, it works well, so the issue just hasn’t worked it’s way up my priority list yet.

I hear ya. Great that it’s running for you! I might pick up some different hardware to run StartOS. Have you heard of any particular setups that people have had lots of luck with?

Have you looked through this list? [Known-Good Hardware Master List] Hardware Capable of Running StartOS - #127 by grapevine