Unable to connect to Bitwarden on Android Tablet

I keep getting this message:

Exception message: Unable to resolve host “url…”: No address associated with hostname.

I’m able to connect to my Start9 Vaultwarden on my MAC and Android Phone. However, I’ve been unable to connect with my new Android Tablet S9 Ultra. I’ve followed all update instructions for ‘secret settings’ and ‘network proxy’ settings. Additionally, I installed my Root CA on my tablet as well. Still, unable to connect as ‘self-hosted.’ After saving URL environment and entering email, I get the exception message noted above. After providing password, I get the same message including “an error has occurred.”

Thanks in advance for your time and help in resolving this issue.


Hi Frank,

Sorry about your connectivity issues with Bitwarden. Could you please clarify if you are attempting to access over Tor rather than .local? And is this the first time you’ve experienced this? How long has it been going on for? Let us know and we’ll be happy to help you further from there.


Trying to connect over TOR. Connecting over TOR on my android phone well long-term but not my new android tablet.

Additionally, I turned VPN back on with Orbot and now just get a generic error message occurred.

I have tried to access Bitwarden using the app from Google Play. When doing so and entering the TOR url for my Start9, I get an exception message noting ‘no address associated with hostname.’ I have also tried to use the firefox beta browser on my android tablet with the Bitwarden add-on. I get the same error message or a simple error has occurred message.

I have followed all the steps on the Start9 site to access vaultwarden via Android. Turned DNS off and completed the ‘secret settings.’

Again, it’s working perfectly on my android phone and my MAC.

Thanks again, Frank

Did you also follow the guides for setting up TOR Start9 | Connecting Remotely

See also Start9 | Running Tor on Android

See also Start9 | Client Setup

Yes. I followed the guides for TOR and connecting remotely on Android. I also installed my Start9 Root CA.

Just double-checked that all settings are correct via those guides.

HMMM. Are you able to connect to anything else via tor. Try this link for example. it is start9’s page http://privacy34kn4ez3y3nijweec6w4g54i3g54sdv7r5mr6soma3w4begyd.onion/

FYI, when reviewing the guides for firefox, note that I’m using firefox beta as instructed in another guide on Start9. To that end, when I got to the browser settings, I cannot locate the proxy settings as I have in the past on Firefox browser.

So I take it you saw the link to this guide at the end too? Start9 | Configuring Firefox for Tor and the specific section for android and firefox beta

I had done that when I was using the Firefox browser. However, in another guide it noted that I need to use Firefox Beta Browser. I cannot locate the proxy settings in the ‘settings’ tab of Firefox beta.

Yes. Using firefox beta browser and the about:config settings.

I cannot access that privacy URL in my firefox beta browser.

I don’t see in the android guide for firefox beta where you need to access the proxy from the settings menu. I don’t use it myself just reading through it. It looks like you set up everything from the search menu. And for graphene users only step 10 says " (GrapheneOS users only): Head to Settings -> Apps -> Firefox Beta -> Permissions -> Photos and videos -> Configure Storage Scopes -> ADD FILE, then navigate to where you placed the proxy.pac file:"

Correct. If that is the case, I followed all the steps for firefox beta correctly. I do not know what GrapheneOS is, so I ignored those settings, correct?

Yes Graphene is just a version of Android

Any thoughts? It’s a brand new android tablet. I’m not sure why it’s not connecting. Seems like I’ve followed all the steps in the guides.

I left word with the team. Hopefully some of them will have suggestions. I’m not familiar with the Android tablet myself. It should work. Keep in mind that sometimes TOR itself is unstable or congested. So maybe give it a little time and try again.

1 Like

Tricky to follow everything and know what the current status is.

It sounds like you can’t access Tor .onions via Firefox Beta browser at all, and you haven’t even reached the stage where you set up the Bitwarden client. Is that correct?

So we’re back to basics, and you situation is “I can’t get Tor working”.

On Android, to access StartOS UI over Tor, we typically use Orbot so that Tor runs in the background at the system level (otherwise you’d just use Tor Browser).


The benefit of Firefox Beta is that you can set it up to work with Orbot’s VPN mode turned off. (Start9 | Configuring Firefox for Tor)

But… Bitwarden Client needs VPN toggled on each time you want to save a new password.

So what I’d like to confirm is…

  1. With Orbot installed and VPN mode turned off… With FF Beta correctly configured, can you access .onion urls?

  2. With Orbot installed and VPN mode on and Chrome added to VPN apps, can you access .onion URLs there?

  1. With Orbot installed and VPN mode turned off… With FF Beta correctly configured, can you access .onion urls?

Answer: No.

  1. With Orbot installed and VPN mode on and Chrome added to VPN apps, can you access .onion URLs there?

Answer: Yes.