[Known-Good Hardware Master List] Hardware Capable of Running StartOS

If you are successfully running StartOS on hardware not sold in our store, please reply here and we’ll add it to this list so others know what options they have. Cheers!

Note: If your device is very close to one listed below, it is likely to work :slight_smile:

Caution: Unplug Wi-Fi dongles as they are known to potentially cause issues. Always use ethernet when possible. Also, consider unplugging everything except power, monitor, keyboard, and mouse when setting up.

PROTIP: Follow your manufacturer’s instructions to update to the latest BIOS before installing, especially if your device is quite old.

Virtualization

VirtManager - Guide
VirtualBox
SynologyNAS Virtual Machine Manager
Proxmox - Guide - Guide (espanol)

ARM Architecture

Raspberry Pi - Not recommended for the Bitcoin stack or other heavy operations - great for file storage, password management, etc

x86_64 Architecture

Purism Librem Mini (Official Support) (Open Firmware / IME Mitigation)

Ace Magic T8
Acer:

  • Aspire 5742 PEW71
  • Swift 1

Alienware Alpha R2
ASRock custom setup w/ i5 and M1505 Megaraid 9260 8i RAID controller
ASUS PN41-S1 Mini PC

Beelink:

  • S12 Intel N100
  • MINI-S12

Custom Hardware Builds (By Motherboard):

  • Asus Z97-E
  • GIGABYTE C246M-WU4

CyberGeek Nano J1

Dell:

  • 3060 Mini
  • 3070 Mini
  • 3540
  • Inspiron:
    • i7559-5012GRY
    • Micro 3050
  • Latitude
    • E5470
    • E6420
    • E6530
  • Optiplex:
    • 3050
    • 3070
    • 7010
    • 7040
    • 7050
    • 9020
  • Precision M4800 Laptop

Gigabyte GB-XM1-3537
GMKtec Nucbox G3

HP:

  • EliteDesk:
    • 800 G1 DM
    • 800 G2 DM (Only 6-10w power draw!)
  • ProDesk 400 G5
  • ProDesk 600 G1 Mini
  • ProDesk 600 G2 Mini PC (Need latest BIOS N22_0259)
  • Proliant ML350P
  • Proliant ML350 Gen9

Intel

  • NUC10
  • NUC11

Lenovo:

  • Thinkcentre:
    • 720q Tiny (11-20w power draw)
    • M710t
    • M920q
    • M93p
  • Lenovo Thinkpad:
    • T470
    • T550
    • x270

Mac:

  • iMac 2017 (with Fusion drive)
  • Mac Mini 2023 (in a UTM Virtual Machine)
  • Mac Mini (A1283, early 2009) - Video
  • Mac Mini (A1347, late 2012)
  • MacBook Air (2015)
  • Macbook Pro (2015) - mini port → ethernet adapter required, no wifi

Minisforum

Morefine M6 - Must add the following kernel parameter: I915.force_probe=4e61
Morefine M600
MSI GP72 laptop
NDiS B533
NitroKey NitroPC
ODROID H3
TRIGKEY AMD Ryzen 7 Mini PC, 5800H (Had to use UEFI boot)
Umbrel Home (lol)

3 Likes

I have successfully installed embassyOS 0.3.3 on old Mac mini (A1283).

Here is the video log from the installation process.

4 Likes

Installed 0.3.3 on a Lenovo Thinkcentre Tiny.

M910q / 8MB RAM / I5-7500T / Crucial
SATA SSD 1 TB, Slot for Nvme empty

Hardware cost 189€, upgrade Kit 2x16GB RAM additional 75€ ( all items refutbished )

Added, thank you for the report!

Successful install of 0.3.3 on System76 Thelio via Proxmox.
Allocated 4 cores + 8gb ram on 1tb nvme.

3 Likes

I got embassyOS v0.3.3 to work on x86 Architecture : HP ProDesk 600 G2 Desktop Mini PC (8GB RAM / 500GB SDD – I’ll upgrade later when I get a chance to get a larger drive). Need to make sure machine is running latest BIOS N22_0259.

2 Likes

I’m running a Docker Swarm on 4 Pi’s and wondering if anyone has tried building a docker container with Start9 OS? Would love to spin one up to check it out.

Please give it a try and let us know :slight_smile:

I’ve got things running fine on a Late 2012 Mac mini (6,1 A1347) that I upgraded 16GB RAM and a 2GB SSD. Everything works fine save for Wifi

1 Like

Running on Asrock mainboard, CPU i5-5600k @3,5GHz quadcore, 2x8Gb ram, raid controller M1505 megaraid 9260 8i with 3x2TB ssd as raid 5! (controller flashed with newest firmware) which leaves me 3,63TB storage! eOS is on an extra ssd with 128GB.

I tried software raid with intel rapid storage first. But this didnt work although linux detected the raid setup but eOS only detected the single ssd`s. eOS didnt detect the raid drive which was in dev/mapper/…
Maybe its somehow possible.
After i faild with this i bought a cheap raid controller. If you want you can buy raid controllers which are 500 bucks, but i only paid 50 bucks for the M1505 9260 8i (but IBM version) the LSI version should be faster during boot but i didnt compare.
I flashed the controller to the newest firmware, this took some time to figure out but if you know how it works its quite simple. Configuration of a raid 5 was also very simple with some youtube input.
Raid 5 needs at least 3 ssd. It is nut a backup setup but its a redundancy setup which lets you fail one ssd. When you insert a new ssd (for the failed one) the system can recover.

Then i installed eOS on a separet drive with only 128 GB.

2 Likes

Really cool setup - would love to hear details on your RAID setup (hardware/software) and any hurdles along the way. I’m sure many folks would love to increase their storage and add redundancy

1 Like

2015 Macbook pro. I had to add a mini port → ethernet adapter to get through setup.
Under wifi it says "RPC ERROR WiFi Internal Error: No WiFi interface available.
Other than that, works like a champ!

2 Likes

Installed 0.3.3 on a Lenovo Thinkcentre 710q tiny. Ethernet needed to be connected without wireless dongle attached. 512 gb SSD and 16gb of RAM. Will be backing up to 1 tb external storage over LAN as recommended.

1 Like

Successful install of embassyOS 0.3.3 on and old laptop I had laying around.
Has been running without issue.

Dell Inspiron i7559-5012GRY
Intel Quad Core i7-6700HQ, 16 GB RAM, 1 TB HDD

Only annoyance experienced was microscopic text on the laptop display.

3 Likes

When you say microscopic text - is this just inherent to your laptop, or is the text within Embassy’s UI specifically a problem? If so, maybe give us some screenshots and we can see if adjustments can be made. We make it a point to have mobile support, but we are considering breaking out mobile, small res, and high res display modes.

Dave,

It is not inherent to the laptop. I have installed other operating systems on this laptop and this is the first time I am experiencing this.

I do apologize for the quality of the pictures.

Here is a link to an album with additional photos.

That’s quite odd - I’ll pass this on to the front end team to see if anything can be done. Are you zoomed way out by any chance? A temporary solution would be to zoom the window by holding the ctrl key and tapping the + key. You can also access from another device of course

Can you let me know the default resolution of this screen?

I have a Lenovo ThinkCentre M93p Tiny I bought from ebay (https://www.ebay.com/itm/293526962748). Works great, except sometimes Tor misbehaves.

  • Intel(R) Core™ i5-4570T CPU @ 2.90GHz
  • 16GB RAM
  • 1TB Techleaf SSD

Synced bitcoind including txindex and bfindex in 19 hours.

1 Like

Embassy OS 0.3.3 working fine on Lenovo Thinkpad T470

1 Like